Архив за месяц: Июнь 2016

Ошибка Mysql mysqli_query(): (HY000/1819): Your password does not satisfy the current policy requirements

При переходе на Mysql 57 стали постоянно появляться ошибки вида:

mysqli_query(): (HY000/1819): Your password does not satisfy the current policy requirements

Выяснилось,что это зверствует новый плагин проверки паролей на уровень сложности, по умолчанию стоит уровень MEDIUM:

mysql> SHOW VARIABLES LIKE ‘validate_password%’;
+—————————————+———+
| Variable_name | Value |
+—————————————+———+
| validate_password_dictionary_file | |
| validate_password_length | 8 |
| validate_password_mixed_case_count | 1 |
| validate_password_number_count | 1 |
| validate_password_policy | MEDIUM |
| validate_password_special_char_count | 1 |
+—————————————+———+
6 rows in set (0.01 sec)

Я изменил на LOW, можно поменять следующими способами:

mysql> SET GLOBAL validate_password_policy=LOW;
Query OK, 0 rows affected (0.00 sec)

или в файл my.cnf необходимо добавить:

[mysqld]
validate_password_policy=LOW

 

Ошибка при загрузке файла руссификации IPS

При загрузке файла руссификации на движок форума Invision Power Services переодически появляются ошибки в некоторых строках вида:

XMLReader::next(): /tmp/IPSGJp1El:5327: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0xD0 0xBA 0x20 0xD0

Мне удалось полечить эти ошибки следующим способом — необходимо вставить пробел после скобки»[» — <word key=»plugin_settings_code_desc» js=»0″><![CDATA[

Например было:

<word key=»plugin_settings_code_desc» js=»0″><![CDATA[Указание …..

Стало:

<word key=»plugin_settings_code_desc» js=»0″><![CDATA[ Указание …..